
Google SketchUp and Kerkythea – fast start 4Architects

Hi every one!  I embarked on this project to show my appreciation and respect to the Kerkythea team, who have had a great impact on my insight into

easy high-quality rendering. I hope you too will find Kerkythea easy to use and as fun as I did. This is an updated and revised version of a tutorial I posted

over at the KT forums.

There are a few points that I need to mention first before you start to learn KT using this tutorial. First of all, because this is an easy-to-use and simplified

tutorial and also an architect-oriented guide, I have ignored some intricate technical material tips. Maybe in the future you will be so impressed by KT that

it will encourage you to learn KT deeper. I have done another follow-up tutorial called Kerkythea – take a deeper look at materials. It is based on more

accurate material making, which may be worth looking at once you have gone through this one. One thing for sure, if you are interested in making true

materials, you need to know about them, so that tutorial will come in handy. In the mean time at this early stage don’t worry about the advanced stuff, you

can ignore it and enjoy simple material making. Also, there is a little known fact about KT that by knowing and using some simple material, light, render

settings with a few simple tips, you will almost certainly start creating great photo-realistic renders. Please note that this is a SketchUp based tutorial. On

other 3d software it may vary somewhat.

Installation – Placing Lights in Google SketchUp – Export

Ok, let’s get started;  first of all, be sure that you have installed the latest version of KT, and appropriate SU2KT Exporter (copy su2kt.rb and su2kt folder

into Sketchup\Plugings folder) for exporting your model to KT. I strongly recommend you to use this installer because it is the easiest to install.  If all is

successful you should have a new toolbar called SU2KT like the one shown below.

KT Toolbar

If you don’t see this tool set in  SketchUp  go to View>Toolbars>SU2Kerkythea and ensure that you have selected and activated this menu. I will only

describe the ones we are concerned with at the moment and these are the 1st, 4th and 5th icon.  They are: “Export to Kerkythea”, “Point Light” and “Spot

Light”.

After you have completed your modeling and texturing in SketchUp it is now time to place your lights and then export your model to KT. Generally we

have two kinds of light, a Point Light and a Spotlight. A typical example of  a point light would be a  general tungsten light bulb and if you put it inside a

shade, then that would be a typical example of spot light in general.
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Examples of Spotlight and Point Light

Now lets use point / spot lights. The icon that looks a bit like the planet Saturn, is the point light while the cone shaped icon is the spotlight. Choose a point

light, click where you want your light to be placed, and click somewhere in your model that shows the range of your light. A dialogue box will appear that

lets you to rename and modify your light’s power. If you use spotlights, the second point shows the light’s target. Easy?….yes that’s all there is to it!

Spotlight Dialogue Box

After placing all of your lights now it’s time to send your model to KT to be rendered. Be sure that nothing is selected because if you have something

selected, a dialogue box will ask you do you want to export selection only? We want to export whole model so make sure you have nothing selected.  So

now click the export button, the first icon in the KT Toolbar. Now you can answer dialogue box with yes/no ( you can change nothing so just click OK).

Maybe you are interested in a clay render that makes your render something like Maquette. If so, then the third  question asked   “export clay model?”

must be answered by “yes”. This is a sample of clay render:
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Clay Render

If you happen to select this, then none of your textures will be exported to KT, and your entire model will have one material (but every object is selectable

separately so that you can modify it, and if you haven’t textured your model then KT will not let you modify each object separately).

TIP: As KT is physically correct, so you must pay attention to your model scale and try avoid off-scale models!!! When your model is opened in KT at first

it’s a bit confusing because of lots of gray lines you see!!! Press “V” on your keyboard. Now it’s better to understand….. isn’t?

Graphical User Interface (GUI)

Being more familiar with the KT interface maybe is the next step we need to quickly look at.  You will find these major parts:

Common Bits

Actual KT Workspace/Interface
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Actual KT Workspace/Interface

Materials

Now we are going to learn about the materials, adjusting them simply and then we can start our architectural rendering job. You can download the files

you need for this here. Using “Ctrl+O” open “mat scene 2.kzx” file. Hit the “Esc” and “Space” on keyboard to ensure nothing is selected and you are

ready to select objects in your scene.  Hit “V” to see your model with textures/colors. Now double click on @material@ the wood-textured object will be

selected. As you see the selected wooden object is wrapped in a yellow mesh and in the “Scene tree view”. A tiny yellow star has appeared beside the

material’s name and shows that it is now selected. Press “Alt+m” for the material editor to appear.

Select Material

KT material editor can be a bit confusing but in fact very simple and handy. There are a few elements within the material editor we need to look at first

and I will go over the most common ones:

Material Editor

[Matte/Phong], Reflectance, Transmittance, Self Luminance, Bump Mapping and Clip Mapping are most used and common parts. Trust me,

understanding  just these parts will end in acceptable renders. Now what do these names mean?  Most materials we see reflect the light that hits them.

The “Reflectance” part of the Material Editor lets you fine tune this property of materials. Some materials like glass, camera lenses and water, let light
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The “Reflectance” part of the Material Editor lets you fine tune this property of materials. Some materials like glass, camera lenses and water, let light

transmit through them so the “Transmittance” part is about this characteristic. You have seen that a candle, neon tubes, safety match or fire and also your

computer monitor glow when it’s dark. “Self Luminance” is about glowing emitter materials such as above. There are lots of materials that when you

touch them you will find that they have scratches, grooves and small dents, or small bumps like raw fabrics. This is very hard to model. You can achieve

this type of relief using a bump map. Another difficult thing to model would be something with lots of tiny holes and very pitted, like a wooden fence. It

would not be wise trying to model this kind of relief. Using a map that masks some part of the material can make it easier to create this kind of effect.  This

is where the  Clip Mapping part comes into play.

Common material features are:

Reflecting – like a wood material

Transmitting – like glass

Emitting Light – like neon bulbs or fire

Bump and Clip Maps

Material Features

Reflection and Shininess

Our wood material has a texture, and its thumbnail is shown as a brown square in front of the “Diffuse” word. Generally we call these colors or textures

as “map”. By right-clicking on the actual word “Diffuse” you can change it. First colored circle lets you to add color, second checkered square lets adding

or change the material texture, the third one is for procedural textures and finally the red multiply sign is to delete color or texture or any other “map”. It is

the same for other items like “ambient” “Specular” “Shininess Map” etc. . . . Note that each time you add any map such as color, texture, etc. to each item

a “weighting” panel will appear further down the material editor panel. Note that if you are adding more than one map at the same time (at this stage I

strongly recommend you to avoid! And if you have done you can delete it by right clicking) whole weights sum must not exceed more than 0.96 because it

means that your material is reflecting more light than receiving!!!

Our material is too matt and dull and needs a bit of  polish in my view. To do this add a weight color (white for example) to “Specular” item and tick the 

“Specular Sampling” box at the same time to have some reflectance on your material. By adjusting and increasing the “Shininess” item, you can have a

polished wood while by decreasing it your wood goes more matt. Change “Shininess” to 5000, 2000, 500, 100, 50, 20, 5 and carefully observe the

differences. Greater number end up as a clear reflect.

To decrease the amount of shininess simply lower the material’s “Weight” (as a tip: how shiny is your material, is directly linked to “Index of Refraction”

under the “Transmittance” part. Note that your IOR (index of refraction) is normally more than 1. Increase it and see the result).
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Settings and Results

Consider that by increasing the IOR amount our material goes more reflective, while how shiny is our material, determines clear reflected environment on

our material. Now if you increase the “Shininess” amount, you’ll reach a point that your material is mirror-like. At this point you can delete specularity and

instead, use reflection. Reflection is much faster. It doesn’t depend neither on IOR nor shininess and you can control it’s amount by “Weighting”.

We are going to make a shiny red plastic. Change materials “Diffuse” from bitmap (I mean wood texture) to red color by right-click over “Diffuse”. Add

white reflection to it. Hit Quick render, and you have a shiny red plastic. When you increase the “Shininess” with a fixed specularity amount (i.e. .96) you

will reach a point that you can use “Reflection” instead. You can also decrease reflection by lowering “weight” of reflection as desired.

More Settings

Now you can make lots of materials, like porcelain, ceramics, polished shiny wooden floors and shiny plastics. All of these materials have a “Diffuse” (that

maybe a color or texture) and some reflections that could be achieved in 2 ways:

“Specular” + “Specular Sampling” and “Shininess” + “IOR”  for controlling1.

Just adding “Reflection”2.

Obviously if you have a perfect reflection , you must use reflection, but if you have a jaggy reflection use Specular. Usually there are a few materials that

have a perfect reflection, in fact most of them have a soft and wide-range which means you can use some “Specularity” on them. For example, aluminum

has no color and just some gray specularity while colored aluminum has a colored specularity.
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Material Editor

Bump Mapping

First of all take a look at these pictures and pay attention to the materials:

Leather Materials
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Leather Materials

There are plenty of materials that have a tiny or huge bumps. In such situations you can add a bump map to your material so you simulate this feature in

the material.

Bump Maps

As a rule, bump maps are black/white maps, the dark parts are deep, and light parts are bumped up parts of the material. Now look at a leather material

setting:

Material Settings

As you see this is a brown material (though I’ve used color you may use a texture instead) + white “Specularity” and also a black/white map as the

material’s bump. I’ve reduced “Shininess” to about 7. This causes a wide range of specularity over our material. You can bring lots of your texture to life

by using a good bump map . For example, ceramic tiles, bricks, rough fabrics, textiles, rough wooden textures  etc. After a while when you became more

expert, it’s possible to use multiple bump maps over your materials.

Self Luminance

Some materials emit light. Candle, neon tubes, computer screen TV and LCD’s are sample of these material type. If you give some “Radiance” to your

material , it will behave as a light source so we call it “emitter” material. If your emitter material has a complicated geometry, render time will become very

enormous. So it’s wise to avoid use of such geometries as light emitter sources. As a trick you can give a color to “Radiance” part but uncheck “Emitter”

part, and then your material will glow but doesn’t give light to environment. Then you van add a point light beside  it to gives light. Here are some samples

of light emitter materials:
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Light Emitter Materials

Clip Mapping

What about pitted materials that have many holes in them. Like fence materials, that have a mesh of tiny holes and pores. In such situations you can use

a black/white map as your “Clip map” texture. Not that just the “WHITE” part would be “VISIBLE” after render. Here are some samples:

Clip Maps

Transmittance

Water, paper, lamp shades, thin fabric curtains and also glass are samples of transparent materials that light passes or transmits through them. Glass for

example lets light to be half-reflected and half-transmitted through it. Water also is the same but at the same time refracts the light and you must add an

“Index of  Refraction” of about 1.3 to it and maybe some bump to be more realistic.

For a thin glass (that we use in windows) add a white “Reflection” and using “Weight” reduce it to 0.24 or a bit more or less (or you may add a color to the

“Reflection” part to achieve a colored glass). Add some white (or color, if you need a colored thin glass) and don’t change “Index of Refraction” at all. See

Image for settings:
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Thin Glass

For thin frosted glass add some reflection (About .24), in the “Transmittance” pane. Add white (or color) to “Transmitted” part. Set “Index of Refraction” to

1. Set “Transmitted Attenuation” to “Fresnel”. Check and select “Transmitted Sampling”. See image below for settings:

Thin Frosted Glass

For wavy water material do the same as thin glass material and then change the “Index of Refraction” to 1.32. also a water texture map to “Bump

Mapping” part.
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Wavy Water Material

Thick glass material (i.e. glass vases or a glass cup) are like water but with “Index of Refraction” of 1.5.

Rendering

In the Toolbar ( Icon-Bar), the third icon from right that is represented by a running man in a green circle is for starting the render process (selecting the

camera and render setting panel). Click on the green running man for the render setting panel to appear. The camera part shows as many “Scenes” as

you have made in your SketchUp model with their exact name as your cameras in KT. “Resolution” part determines your render size. Simply type your

desired render size by “width*height” to change it.

Just beneath it the “Settings” part is a preset of render settings that each one would end to a different result. For fast draft render, choose preset no 03

(Photon Map-Quick) and for final render preset no 06 should be good enough. Maybe for exterior renders preset no 17 is the best one. If your computer

has more than one processor, you can choose a different number under “Threads” to match your processor numbers. For example if you have 4

processor you can force all 4 of them by choosing 4, in front of “Threads”.

Settings

To see the render result, at the left of the green runner, there is a tiny landscape icon. Click on it. When your render has finished, you can save it by

choosing “Save Image”.
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Tips and Tricks

Save your scene for further reference using “CTRL+S”.

KT separates objects by their material’s names. So give a different material to each part of your model and avoid use of same color/material for

those parts that you need them to be defined and modified separately. For example if you need reflection for top face of your wooden brown table,

then change the face material. Easily select the table material, hit “create material” key, name your new material, and repaint that face.

Start name of your thin-glass materials (i.e. your windows glass is a thin glass) with TG_ , then when you export your model to KT, they will be

recognized as thin glass materials.

Easily paint your lights with desired color in SketchUp , so that they emit the same color in KT.

Each time your confused, easily “reset” your material and start over.

Always be aware of this physics law: reflection+refraction must not exceed more than 1.

To avoid complicated geometry, when it is an emitter material and it is flat, you can use a single emitter plane+clipmap instead of making real

geometry.

Example of Emitter Plane

If you need some partial changes and not your entire model or need more cameras or lights, there is no need to re-export your model to KT. Just

add new cameras (scenes in SketchUp), lights and materials or geometries and select everything you need to be changed (scenes in Sketchup

will be exported automatically as cameras) while exporting to KT and say “YES” to first question on KT exporter that asks you: “Export selection

ONLY?”. Then in KT from “File” > “Merge”, merge these 2 files and adjust merging process as you desire.

From the KT site’s download page, download “Globals” you need and install them (from “File” > “Install Library”). Now you can add virtual

environments to your model from: “Insert” > “Globals” to change your environment from a plain sky to desired one.

From the KT site download page, download material packs you need. There are plenty of them. Then open your library from “Library Selection” on

right part of KT main interface. You can easily add the desired material to your model as follows -  Select material or object you wish from left

“Scene Tree”. Double-click on desired material in the right library.

Install my “Fast Start 4Architects” material library (its full name is “Fast Start 4Architects.mat.zip”). There are some mostly used materials in it and

you can change them easily or learn from them.

Open the material test scene that I’ve uploaded. First unzip “mat scene 2.zip” and then open “mat scene 2.kzx” file and test your materials on it.

Get familiar with the KT forum, there are lots of good helpful guys there .

My special thanks goes to Frederick (KT team member) who helped me a lot and invited me into the KT forum.

ENJOY RENDERING!!!!

Majid
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Majid
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